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1. VIRUS & SPYWARE: Run full Scans from all available Anti-virus and Anti-malware programs: For
details, see my ANTI-MALWARE TOOLS & TIPS sheet. (In additions to your preferred Anti-Virus
Program scan, I recommend the following scans: MalwareBytes AntiMalware, Super AntiSpyware,
SpyBot Search & Destroy.  

2. REMOVE ALL UN-NECESSARY BROWSER ADD-ONS & 3rd PARTY TOOLBARS: Remove all
un-needed toolbars, add-ons and plug-ins from Firefox and IE. (Some are removed in the browser and
others are removed from Add/Remove Programs. )

3. REMOVE ALL LARGE FILES FROM THE DESKTOP: 
a. The Desktop is actually a folder located at: (C:\Documents and Settings\<UserName>\Desktop). To

see the size of the Desktop folder, go to (C:\Documents and Settings\<UserName>\). Right-click
the "Desktop" folder then click Properties. It should be under about 2 MB. Yes, 2 MB, not 2 GB.

b. Large files actually located on the desktop can slow down the boot time as well as regular
operations. Large files should never be located on the desktop. This includes program files and
data files. Moving files off of the Desktop can make a big difference because some users are in the
habit of storing everything on the Desktop. In addition, “System Restore” constantly monitors the
Desktop Folder; the smaller the folder the less time System Restore spends on it. 

c. Basically, the Desktop should have nothing on it but Shortcuts and Folders with shortcuts in them.

d. Any files that you find on the Desktop should be moved to either the "My Documents" folder or to a
folder on the C Drive root: (IE: C:\data). If desired, you can put shortcuts on the Desktop to those
files or programs. 

e. Along with this, you should never download files to the Desktop. It is too easy to forget and leave
them there. Create a folder just to use for downloads. For example: C:\Downloads

4. REMOVE ALL DESKTOP SEARCH TOOLBARS: Including Google Desktop, MSN Desktop, Copernic
Desktop, etc. (Control Panel > Add/Remove Programs).

5. REMOVE ALL UNNECESSARY SOFTWARE: (Control Panel > Add/Remove Programs). 

6. DISABLE SLOW OR UNNECESSARY "BACKGROUND" PROGRAMS, PROCESSES, & SERVICES 
a. For details on how to disable Start-up programs and proceses, see my XP TIPS sheet in a section

called STARTUP MANAGEMENT. 

b. UNNECESSARY STARTUPS: Eliminate un-needed programs that start-up during boot.  I
recommend using a utility called "Codestuff Starter" or other startup manager utilities. ):    
http://www.snapfiles.com/get/starter.html  .  (I do NOT recommend using "MSCONFIG").  Warning: On the
"Startups" Tab, there is a startup listed that has no name and no description. Do not disable this
entry or Windows will not boot. Unless you are experienced, stay away from the "Processes" &
"Services" tabs.

c. UNNECESSARY SERVICES: If you dare, you can try disabling un-needed Services. See this link
for info on disabling non-critical Windows Services: www.blackviper.com   

d. ANTI-MALWARE suites like TrendMicro, Symantec, McAfee and others slow down the PC and the
boot time. If your PC is more than 3 years old, you should remove your AntiMalware Suite and
replace it with Microsoft Security Essentials.

7. SLOW BOOT TIME: Try downloading, installing and running the SOLUTO Utility. It tells you exactly
what programs are slowing down your boot time and by how much. It also tells you which can be
safely removed from the startup or may be delayed.  
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8. BIOS HYPERTHREADING: Many PC’s Hardware support Hyperthreading, but have it turned OFF by
default in the BIOS (System Setup). Hyperthreading can speeed up a PC significantly. Go to the BIOS
setup and, if it is available in the advanced CPU settings, turn ln Hyperthread. Current versions of XP
totally support Hyperthreading if the hardware does. Reboot a couple of times to allow XP to install the
necessary drivers. 

9. RAM: Make sure you have at least 1 GB of RAM installed. 2 GB is even better if you use memory
intensive programs like Photoshop. (Right-click My Computer > Properties > General Tab). 

10. HARD-DRIVE FREE SPACE: Make sure Hard-drive "C:" has plenty of "Free-space". When Drive "C:"
gets too full, XP will run slow, boot slow, and crash a lot. XP needs lots of room for Temporary files.
Microsoft says at least 15% of drive C should be free and available for XP and program needs. One
emergency way to get some quick space is to disable "Hibernate". 

11. HARD-DRIVE HEALTH & SPEED: Install and run the HDTUNE Utility: 
a. Make sure the “C:” drive’s health is OK. If the health is in doubt, install and run the Crystal Disk Info

utility to confirm its health status. 

b. Run the Benchmark test for data transfer rate. NOTE: A 5400 RPM Drive should run at least 30
MB/sec and a 7200 RPM drive should run at least 85 MB/sec, otherwise your PC will be slow. 

c. Run the “Slow” Error scan to check for data corruption. If any bad blocks, run chkdsk /f /r.

12. VIRTUAL MEMORY: (Control Panel > System > Advanced Tab, "Performance", click <Settings>
button > "Performance Options" window > Advanced Tab). Under "Virtual Memory", click <Change>. If
you have added RAM to the system since XP was installed, the virtual settings are probably wrong. XP
only detects the RAM amount during the XP install.

a. Verify that either Item 1 or Item 2 is set up properly: 
1) Select "� Custom size": with the Initial size set to a value of 1½ times the physical RAM size (in

MB's) and the Maximum size set to 3 times the physical RAM size (in MB's) (IE: with 512 RAM:
Initial size = 768 & Maximum size = 1536) Warning: You MUST click the <Set> button for the
change to take.  

2) Select "� System managed size".     

b. If you have a second physical hard-drive, you can speed up XP by using it for the Virtual memory
paging file. On the Virtual Memory Window, select it for the paging file location. 

13. SYSTEM RESTORE AND OTHER RESTORE PROGRAMS: 
a. A PC should only be running one Restore program.  Running "XP System Restore" along with

other restore programs like Norton "GoBack" will slow down the PC dramatically.  Plus, it is a big
waste of hard-drive space since both programs reserve and use a lot of drive space.  Make sure
only one "Restore" Program is running. If you are using Norton GoBack, you should disable
Windows "System Restore". 

b. In general, System Restore only needs to be monitoring Drive "C:" unless there are system files on
other drives. This is unlikely. XP's default settings is to monitor all available drives including
external drives. You can turn off the monitoring of all drives except Drive C in the System Restore
settings: (Start > All Programs > Accessories > System Tools > System Restore > System Restore
Settings). 

c. If there is a second physical hard-drive in the PC, you can put all User data on that second drive.
Then turn off System Restore on the second drive to speed up processing. The "My Documents"
folder can even be relocated to a drive other than "C:". 
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14.  SPEED vs VISUAL EFFECTS: (Control Panel > System > Advanced Tab, "Performance", click
<Settings> button).  The fewer visual effects, the faster XP will run. On the "Performance Options"
window > Visual Effects Tab, uncheck all boxes except: "� Use Common Tasks in Folders",  "� Use
Drop Shadows for Icon labels". Optionally check "� Use visual styles on windows and buttons" to allow
the blue "FisherPrice" taskbar and window dressings. (Note: It is normal for the radio button to end up
on "� Custom" after you check the boxes. WARNING: Any changes here will reset all your Visual
Properties back to default.   (Right-click on Desktop > Properties > Appearance Tab > click the Advanced button to

re-customize).      

15.  HARD DRIVE OPTIMIZATIONS: 
a. INDEXING: For best speed on older PC’s, turn off indexing for all Hard-Drives. (X represents your

hard-drive letter).
1) (My Computer > right-click Drive X: > Properties > General Tab). Un-check the box: “� Allow

indexing Service.” Choose: “� Disable on all folders and subfolders”, "� Apply changes to X:
Subfolders & files". (Respond "Ignore All" to any "Access denied" messages)

2) Indexing Service: (Control Panel > Administrative Tools > Services).  Double-click Indexing
Service and change the Startup type to "Disabled".

b. ERROR-CHECK: Run on all your hard-drives: (My Computer > right-click Icon for Drive X: >
Properties > Tools Tab). Then, under Error-checking, click <Check Now>. Choose � Automatically
fix errors & � Scan for and attempt recovery of bad sectors. On Drive C, you will have to restart the
PC and the scan will run during the boot.

c. CCLEANER: Run the CCLEANER Utility to remove un-needed Files & Registry entries.

d. DEFRAG: Defragment all hard drives once or twice a year. 
1) Before doing a defrag, do the following tasks: a) Empty the Recycle Bin; b) Compact all Mail

Folders; c) Set the Power Options > Power scheme to "Always On"; d) Disable "Hibernate". e)
Make sure you have run CCleaner; f) Do a System Restart; g) Continue with the next step.

2) Do the Defrag: (My Computer > Right-click Drive X: > Properties > Tools Tab > Defragment
Now button >  Defragment button.) (Actually, I prefer the "JKDefrag" Utility)

3) If there are a lot of scattered unmovable files, run the Microsoft "Page Defrag" Utility.

4) "Glary Utilities": Run the Registry Clean module and then the Registry Defrag  module.

e. SPINRITE: If available, run the SpinRite program on each hard-drive. NOTE: Hardware errors can
slow down a system and no error indications. ($90.00) http://www.grc.com/cs/prepurch.htm 

16.  MALWARE MONITORING PROGRAMS: Most Anti-malware programs have “Real-Time Protection”
that constantly monitor for changes on all the hard drives. Some programs like Microsoft Security
Essentials allow you to specify that certain drives or folders NOT be monitored. If you have data-only
drives, you can choose to not have them monitored, thus speeding up the system overall.  

17.  EVENT VIEWER: If XP sucessfully recovers from errors they are never reported to you, XP jus truns
slower. Look in the Event Viewer to see if any errors are occurringand fix the cause.: (Right-click My
Computer > Manage > Event Viewer > System, then Application). 

18.  CPU TEMPERATURE HOT: Many CPU's will throttle down when overheating, and this slows down the
PC's performance. Verify temperatures either with a utility program like "SpeedFan" or look in the
BIOS.  Clean dust from all fans, heatsinks, grills, & the power supply. 
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19.  SPEED UP THE "LOG-OFF"/"SHUTDOWN" TIME: Install a Windows service called "User Profile
Hive Cleanup Service" from: 
http://www.microsoft.com/downloads/details.aspx?FamilyId=1B286E6D-8912-4E18-B570-42470E2F3582&displaylang=en

20.  LAPTOP CPU PERFORMANCE: Laptops frequently have a setting to slow CPU speed to save battery
power. If you are plugged in, it should run at full speed. You can override the settings for battery
power and make it run full speed all the time, but it will drain the battery faster. (Try going to Control
Panel > Power Options > Advanced settings). Every laptop is different, so I cannot guide you further.

21. SPEED UP YOUR E-MAIL:  The larger your mail system, the slower your mail runs. This will not speed
up XP but will speed up your e-mail. Your e-mail client will open faster:

a. Remove/save/detach all attachments, empty the trash.

b. Archive Old Mail: 
� THUNDERBIRD: See the THUNDERBIRD TIPS" on my site at www.jimopi.net
� OUTLOOK:      http://email.about.com/od/outlooktips/qt/et_archive_mail.htm

� OUTLOOK EXPRESS: The only free option seems to be this Utility. (I have not tried it):
Http://www.expressarchiver.com/download/ExpressArchiverLite.exe    

c. Compact Mail Folders:  
� THUNDERBIRD: (File > Compact Folders).   
� OUTLOOK:  (Right-click Personal Folders > Properties > Advanced > Compact Now). 
� OUTLOOK EXPRESS:  (File > Folder > Compact All Folders).

22. LAST RESORT: Reinstall Windows from scratch.     
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