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Here are lots of ideas to help speed up Windows 7 o n an older PC.  On newer PC’s you
will probably not notice any difference in speed.  NOTE: Most of the changes below require
Administrator privileges. 

1. VIRUS & SPYWARE: Run all available Anti-virus and Anti-malware programs. See my ANTI -
MALWARE TOOLS & TIPS sheet. Note also that some Anti-malware suites slow down older PC’s.  

2. REMOVE BROWSER ADD-ONS & 3rd PARTY TOOLBARS: Remove all un-needed toolbars,
add-ons and plug-ins from Firefox and IE. (Some are removed in the browser and others are removed
from Add/Remove Programs. )

3. REMOVE ALL DESKTOP SEARCH TOOLBARS: Including Google Desktop, MSN Desktop,
Copernic Desktop, etc. (Control Panel > Add/Remove Programs).

4. REMOVE ALL LARGE FILES FROM THE DESKTOP: 
a. The Desktop is actually a folder located at: (C:\Users\<UserName>\Desktop). To see the size of the

Desktop folder, go to (C:\Users\<UserName>\). Right-click the "Desktop" folder then click Properties. It
should be under about 2 MB. Yes, 2 MB, not 2 GB.

b. Large files actually located on the desktop can slow down the boot time as well as regular
operations. Large files should never be located on the desktop. This includes program files and
data files. Moving files off of the Desktop can make a big difference because some users are in the
habit of storing everything on the Desktop. In addition, “System Restore” constantly monitors the
Desktop Folder; the smaller the folder the less time System Restore wastes on monitoring it. 

c. Basically, the Desktop should have nothing on it but Shortcuts, and Folders with shortcuts in them.

d. Any files that you find on the Desktop should be moved to either the "My Documents" folder or to a
folder on the C Drive root: (IE: C:\data). If desired, you can put shortcuts on the Desktop to those
files or programs. 

e. Along with this, you should never download files to the Desktop. It is too easy to forget and leave
them there. Create a folder just to use for downloads. For example: C:\Downloads

5. REMOVE ALL UNNECESSARY SOFTWARE: (Control Panel > Add/Remove Programs). 

6. DISABLE UNNECESSARY "BACKGROUND" PROGRAMS, PROCESSES, & SERVICES: 
a. Eliminate un-needed programs that start-up during boot. (I do NOT recommend using

"MSCONFIG").  I recommend using "Codestuff Starter", "Glary Utilities" or other startup manager
utilities. Warning: On the Codestuff Starter "Startups" Tab, there is a startup listed that has no
name and no description. Do not disable this entry or Windows will not boot. Unless you are
experienced, stay away from the "Processes" & "Services" tabs.

b. If you dare, you can try disabling un-needed Services. See this link for info on disabling non-critical
Windows Services: www.blackviper.com      

7. CPU PERFORMANCE: (Control Panel > System & Security > Power Options). Click "Show additional Plans".
Select: "� High Performance".    

8. RAM: Make sure you have at least 1 GB of Memory. 2 GB is better.  (Control Panel > System and security >

System). You need even more if you use RAM intensive programs like photo or video editing.   
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9. HARD-DRIVE FREE SPACE: Make sure Drive “C:” has plenty of Free-space. When Drive C: gets
too full, Windows 7 will run slow, boot slow, and crash a lot. Windows needs lots of room for
Temporary files (> 15% free, maybe more). 

10.  HARD-DRIVE HEALTH & SPEED: Install and run the HDTUNE Utility: 
a. Make sure the “C:” drive’s health is OK. If the health is in doubt, install and run the Crystal Disk Info

utility to confirm its health status. 

b. Run the Benchmark test for data transfer rate. NOTE: A 5400 RPM Drive should run at least 30
MB/sec and a 7200 RPM drive should run at least 85 MB/sec, otherwise your PC will be slow. 

c. Run the “Slow” Error scan to check for data corruption. If any bad blocks, run chkdsk /f /r.

11. THEME: Some Themes run faster than others. To change to the Classic 98/XP look and get improved
performance from an old PC, go to (Control Panel > System and Security > System > Advanced system settings >
Advanced tab > Performance "Settings" button > Visual Effects tab).

a.  Un-check "� Use visual styles on windows and buttons". OK, OK to exit.
b.  Note: Themes and Color schemes affect each other in mysterious ways.    

12.  COLOR SCHEME: (Control Panel > Appearance and Personalization > Personalization > Window
color).  If Aero is on, click "Advanced appearance settings....".  If Aero is off, you will already be at the
classic Appearance settings" window). Note: Some Color schemes run faster than others:  Fastest is  
Windows 7 Classic (all visual effects disabled. See above), VeryFast is Windows 7 Basic (any
non-Aero theme), Fast is Windows 7 Aero with transparency disabled, Slowest is Windows 7 Aero with
Transparency on. 
a. If Aero is on, you can disable transparency at this time, (Control Panel > Appearance and

Personalization > Personalization > Window color). Uncheck the box: "� Enable Transparency".
WARNING: Making these changes will set most, if not all, of your Display/Desktop customizations
back to default.

13.  SPEED vs VISUAL EFFECTS: You can improve the speed of Windows 7 on an older PC by
reducing the overall number of Visual Effects running in the background. (Control Panel > System and
Security > System > Advanced system settings > Advanced tab > Performance; "Settings" button > Adjust visual effects).

a. To get maximum speed on an older PC (Windows Classic mode), un-check all boxes except "�
Smooth edges of screen fonts, "� Smooth scroll list boxes", "� Use Drop Shadows for icon lables
on the desktop", "� Use visual styles on windows and buttons", and any other desired visual
features. WARNING: Every time you make a change here, some or all of the Desktop Appearance
Personalization settings will reset back to default.

b. Click OK, OK to return to the "System" window.
c. At this point you can add a custom image for the desktop, but don't turn on any "Themes" or you

will re-enable various visual effects.   

14.  VIRTUAL MEMORY: (Control Panel > System and Security > System > Advanced system settings > Advanced tab >

Performance "Settings" button > Advanced tab > Under "Virtual Memory", click <Change>). 

a. If you only have one hard drive, make sure the box is checked for: "� Automatically manage
paging file size for all drives". (This is the default).

b. If you have a second Hard drive, you can select it for the paging file location.
1) First, uncheck the box for "� Automatically manage paging file size......."
2) Verify the following is selected: "� Custom size": 
3) Select a drive for the Paging file, then:

i) If you have 1GB of RAM, set both the Initial size and Maximum size to 2048 (in MB's). 
ii) If you have 2 GB of RAM, set both the Initial size and Maximum size to 3072 (in MB's). 
iii) If you have 3 or 4 GB of RAM, set both the Initial size and Maximum size to 512 (in

MB's).  (Recommended from www.tweakguides.com)
iv) Warning: You MUST click the <Set> button for the change to take      
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15.  HARD DRIVE OPTIMIZATIONS
a. INDEXING: Customize or disable indexing. Indexing is constantly running in the background to

make the Search function appear speedier.  
1) CHANGE INDEXING:  (Control Panel > System and security > System > Performance Options and tools >

Adjust indexing options). Basically you only need the "Users" Folder and the "Start Menu" indexed.
Click <Modify> to change the drives and folders for which Indexing operates.

2) DISABLE INDEXING: (Control Panel > Programs > Programs and features > Turn Windows features on or

off).  Uncheck the box for "� Indexing service".

b. WINDOWS SEARCH: Disable Windows Search (Control Panel > Programs > Programs and features >

Turn Windows features on or off). Uncheck the box for "� Windows search". (Warning: This may impair
the performance of Windows 7.)    

c. ERROR-CHECK all hard-drives: (My Computer > Right-click Drive X: ICON > Properties > Tools Tab >

Error-checking > click "Check Now"). Check "� Automatically fix errors & � Scan for & attempt recovery
of bad sectors. Click "Start". For Drive C, click "Schedule Disk Check" & then restart the PC. The
scan will take place during next boot. 

d. CLEAN TEMP FILES: Run the TFC (Temp File Cleaner) or CCleaner Utility to remove
un-needed files.

e. DEFRAG: 
1) Before doing a defrag, do the following tasks: a) Empty the Recycle Bin; b) Compact all Mail

Folders; c) Set the Power Options > Power scheme to "Always On"; d) Make sure you have
run CCleaner; e) Do a System Restart; f) Continue with the next step.

2) Do the Defrag: (My Computer > Right-click Drive X: > Properties > Tools Tab > Defragment Now button >  

Defragment button.) (Actually, I prefer the "MyDefrag" Utility). See the DEFRAG section my
"WINDOWS 7 TIPS" sheet.

3) If there are a lot of scattered unmovable files, run the Microsoft "Page Defrag" Utility.

4) Registry DEFRAG: Using "Glary Utilities", run the Registry Clean module and then the
Registry Defrag module.

f. SPINRITE: If available, run the SpinRite program on each hard-drive. NOTE: Hardware errors can
slow down a system and with no error indications.

16.  SYSTEM PROTECTION (SYSTEM RESTORE): (Control Panel > System and Security > System >

Advanced system settings > System Protection tab > Protection settings:  "Configure" button) .

a. If you have more than one hard drive or partition, make sure System Protection is running only for
Drive C. 

b. If a 3rd party restore program is running, make sure disable the Windows System protection on all
drives. More than one restore program wastes space and slows the PC.

17.  VIDEO ADAPTER DRIVER: A downlevel or incorrect Video Adapter Driver can slow down a PC.
(Control Panel > Appearance and Personalization > Personalization > Display > Adjust resolution > Advanced Settings >
Adapter tab): Make sure the Adapter Type matches your video hardware. If it is only identified as
"Generic", "Default", or "Standard", you will not get the best results. You should try to install the correct
Video Adapter driver either from the Manufacturer or from Microsoft updates.  
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18.  HARDWARE: If a hardware component is your bottleneck, the easiest way to find out is by using the
built-in utility program that assesses the main hardware components of your PC and gives them a
numbered index value (Currently from 1 to 5.9). You can see the results of this assessment at (Control
Panel > System and Security > System > Windows Experience Index) . If you can, upgrade the component with the
lowest number.

19.  COMPACT MAIL FOLDERS: This will not speed up Windows 7, but it will speed up your mail.
a. Remove/save/detach all attachments, empty the trash.

b. Archive Old Mail: 
� THUNDERBIRD: See the THUNDERBIRD TIPS" on my site at www.jimopi.net
� OUTLOOK:           http://email.about.com/od/outlooktips/qt/et_archive_mail.htm

� WINDOWS LIVE MAIL: (Near as I can tell, there is no archive function. Use (File > Export >

Messages > WLM) and save to an empty folder. (I have not yet figured this out for sure) ???  

c. Compact Mail Folders:  
� THUNDERBIRD: (File > Compact Folders)   
� OUTLOOK:         (Right-click Personal Folders > Properties > Advanced > Compact Now) 
� WINDOWS LIVE MAIL:  (Right-click Personal Folders > Properties > Advanced > Compact Now) ??? (Not

verified)   

20.  PERFORMANCE OPTIONS: For more ideas, see  (Control Panel > System and security > System >

Performance Information and tools > Advanced Tools).  

21.  DISABLE UNUSED DEVICES IN THE BIOS: The BIOS in your PC has a listing of all active
devices (ie: Serial Port 1, Serial Port 2, Game Port, MIDI Port, Infrared, Bluetooth,  etc). Disabling any
devices that you never use can speed up Windows 7 and improved reliability by reducing the chance
for Interrupt conflicts between devices. 

22.  LAPTOPS: Laptop Processors run slower when on Battery power to conserve energy. Plug-in the
laptop to get maximum speed. Some Laptops can be configured to run the processor at full speed
under battery power, but it will drain the battery faster.  (See Power Options > Advanced settings). 

23.  LAST RESORT. Reinstall Windows from scratch.    
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