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THUNDERBIRD ON-LINE KNOWLEDGE BASE:        http://support.mozillamessaging.com/en-US/kb/   

TROUBLESHOOTING TIPS:
 From Mike Tech Show: 

 Turn on logging:   http://www.lifewire.com/pop-imap-smtp-traffic-thunderbird-1173156

SET UP THUNDERBIRD: See my Thunderbird Setup sheet; 
http://www.jimopi.net/PDFs/Word%20Pro%20-%20Thunderbird_Setup.pdf

SWITCHING TO THUNDERBIRD (From Windows Mail or Wind ows Live Mail):
 Copy and paste this link into your browser:

https://support.mozilla.org/en-US/kb/switching-thunderbird#w_switching-from-windows-mail-or-wi
ndows-live-mail-to-thunderbird

IMAP OR POP?   The tips below assume you know which kind of email you are using. To find out
what kind of mail your Thunderbird is set up for, go to (Tools > Account Settings > Server Settings)

 Some E-mail providers offer you the choice of using either IMAP Mail or POP Mail protocol. What's
the difference? It really boils down to just one thing. Do you want your mail kept on the provider's
server or on your local PC? Here are some details: 

 IMAP: E-mail is stored on the provider's server and can be accessed from any PC anywhere. You
can set up Thunderbird on several different PC's to access the same IMAP Account or use a
Browser from remote locations. Although some providers offer you a lot of storage space, once it
fills up, either your mail stops working or they will start deleting your oldest mail.  Thunderbird does
allow you to selectively move mail to your PC, thus saving mail that may be deleted by the provider.
Note: When first 

  a new IMAP Account on Thunderbird (or any IMAP client), it takes extra time to initially synchronize
all the folders. Be patient. 

 POP: E-mail is stored on your PC. Each time you log-in, all the e-mail on the server downloads to
your local PC. Once on your PC, mail cannot be accessed from any other location. Mail that has
not yet been downloaded is available via other PC's using a Browser. E-mail storage is limited only
by the size of your hard drive. At some point your built up mail will start slowing down Thunderbird.
You can resolve this by archiving your older e-mails. See my Tips on ARCHIVING MAIL.

ATT / YAHOO / SBCGLOBAL  MAIL SERVERS
        As of 5-2021, all ATT mail providers are us ing the following mail servers . This includes

sbcglobal, Prodigy, Ameritech, currently.com,and YA HOO.    THIS MAY ONLY AFFECT POP3
MAIL. Currently.com (formerly att.net)

POP3 Mail Server =  inbound.att.net   port 995  SSL
SMTP Server       = outbound.att.net   port 465  SSL

ADD-ONS FOR THUNDERBIRD:
 "SEEK": This add-on adds advanced search and sort functionality
 "LIGHTNING": This add-on adds full Calendaring funtionality.
 Theme Font and Size Changer:  http://https://addons.mozilla.org/en-us/firefox/addon/theme-font-size-changer/  

MAIL VIEW CHANGE: 
 The Ver 139 update changed the default view to “CAR DS”. To Change the view back, go to

Settings > Appearance > Message List: Change View S tyle from Cards View to Table View :
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ADDING AN AUTOMATED SIGNATURE TO YOUR MESSAGES:
1. Here is a Link to the Mozilla Tutorials for Signatures:        

http://https://support.mozillamessaging.com/en-US/kb/signatures?s=signature&as=s

2. First you have to find out which mail format you use. Do you compose your mail in SIMPLE TEXT
or HTML?  
a. To find out: (Tools > Account Settings). Select Composition & Addressing under the desired Account

Name). 
b. Is the box checked or unchecked for:   "Compose messages in HTML format"? 
c. Warning:  You can use a plain text signature in an HTML email, but you don't want to use an

HTML Signature in a plain text email (Garbage will show up).

3. METHOD 1 (Simple): Follow this youtube tutorial: http://https://www.youtube.com/watch?v=5OVk6Y9HTMQ Note:
that if you use this method, you either need to stick to simple text or be knowledgable about
manually writing HTML Commands. 

4. METHOD 2 (Hard): (You need to either know HTML or use an HTML Editor).
a. Manually create a separate “.TXT” or “.HTML” signature file using a text editor such as Notepad

or Wordpad, or an HTML Editor such as Nvu, Open Office, (or even Microsoft Word if you
must).  
1) Using an HTML editor or a word processor, start a New Blank Document. 

2) Put in all the info you want shown in your emails and format the style as desired. 
3) "Save As" a  “.txt”, “.htm” or “.html” type file, naming it whatever you want and storing it

anywhere you want (ie: MySig1.html).  
4) Note: (I use an HTML Editor called “Nvu/Kompozer” to create & edit my HTML signature

files. It makes a cleaner file and does the formatting for you.  In my opinion Microsoft
"WORD" sucks for doing HTML. )

5) I suggest that you leave the "Title" field blank in the HTML Text source code. 

 Once the file is created, go to Thunderbird and do the following:  (Tools > Account Settings >
select your Account Name on the left > click the box " Attach the signature from a file" > click the “Choose”
button).  Browse to find your new txt, htm, or html file, select it, and click Open, then click OK
to exit Account Settings.

 Now when you send a note or reply to a note, your custom name-info will show at the end. 

 At this point you can also choose where you want the Signature to appear when replying.
(Tools > Account Settings > select Composition & Addressing under the desired Account Name) .  Select "
Automatically quote the original message when replying, Select "start my reply above the
quote" and place my signature "below my reply (above the quote)". (This is my personal
preference).   

ARCHIVING MAIL: 
 Archiving old mail reduces the size of your active mail system and speeds up the performance of

Thunderbird. 

 Archiving POP Mail (which is already on your PC) moves it from the “active” section of Thunderbird
to an “Inactive” section of Thunderbird thus speeding up your mail. 

 Archiving IMAP mail, moves it from the provider’s E-mail Server to your PC, so it cannot be deleted
by the Provider (especially AOL). This may or may not speed up Thunderbird, but if your allowed
server space is getting full, archiving is a good alternative if you do not want to delete old e-mails.

 To archive mail: 
1) First create a sub-folder under Thunderbird's "Local Folders" category: Click on Local Folders

to highlight it (on the left), then (File > New > Folder). Name the new folder and make sure that the box below
says “Create as a subfolder of: Local Folders ).  My choice is to create a subfolder called something like  
"Archived Mail 2010", then create individual sub-folders under that Folder to help with
organization. "MISC Stuff", "Business Stuff", "Tax Stuff", etc.
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2) Highlight the e-mails desired with the mouse and drag them to your new "Archive" folder. You
can highlight many messages and either drag them all at once or right-click and select Move
ToLocal Folders<Foldername>

3) COMPACT: Moving mail to “Local Folders” gets the mail out of your active mail system, but still
does not reduce the size of the mail system. For this, do a “Compact Folders” by (File > Compact
Folders). Restart Thunderbird and your mail should run faster. 

CALENDAR:
 The calendar add-on for Thunderbird is called Lightning. 
 Setting up the Lightning Calendar to use Google Calendar on Thunderbird. 

http://maketecheasier.com/integrate-google-calendar-to-thunderbird/2011/10/14

COLUMN HEADERS: Customize...
1) On the line that shows the column headers, there is a funny little Icon wayyyy on the right. If you

click that Icon box, it lets you select which column headers you want to add or delete.

2) You can also drag the column headers left and right into the sequence you like best. This is a little
tricky, but play with it. 

3) You can also Resize any of the column widths. This is also a little tricky but does work. 

4) NOTE: When you add, delete, drag, or resize column headers, this affects only the folder you are
currently looking at:  If you are in the INBOX, only the INBOX Column headers change. 

5) To make the header changes affect ALL your folders (Globally), click that funny Icon on the wayyy
right. At the bottom of the list, hover over the option called: "Apply columns to...", then hover over
"Folder and its children...", then hover over your email address “ie: xxxxx@xxxx.com”. Your email
address should show up a second time, then click it.   

COMPACTING MAIL FOLDERS:
 Unless you regularly compact the mail folders, the size of your mail system grows and grows,

eventually slowing down your mail. 
1. Deleting or archiving old emails is only the first step.

2. Empty the Trash (File > Empty Trash)

3. Compact the Folders: (File > Compact Folders). 

 Automatic compact: (Tools > Options > Advanced > Network & Disk Space Tab). Check:  compact folders
when it will save over: 5000 KB (5 MB). If you get messages to compact too frequently, you can tell
it to compact without notifying you or you can change the "Save Over"  value to a higher number. 

FONT SIZE CHANGE
 BIGGER: If the font size in your mail is too small to read, simply Hold down <Ctrl> and press the +

key until the size is right. This will remain in effect until you close Thunderbird. (- key = smaller). 

 CHANGE DEFAULT FONT SIZE OF EMAILS: If you want to permanently make the default font
size larger, go to (Tools > Options > Display icon > Formatting tab > Advanced button) . Change the value in the
"Minimum font size" box to a larger number. Something like 18 or 20 works good for a High
Resolution Monitor. 

 CHANGE THE FONT SIZE OF MESSAGE LIST PANE AND ALMOST EVERYTHING.
1) Open Tools > Options > General.  Scroll down to “Config editor” and click it. . 
2) Search for:    layout.css.devPixelsPerPx
3) Right-click on layout.css.devPixelsPerPx, Click Modify, and enter a value of 1.20 or 1.25 or 1.5

or 2.0. (The larger the number the larger the text).
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 CHANGE FONT SIZE OF  EVERYTHING:This does not work above version 60.  See the add-on
called “Theme Font & Size Changer”.  
http://addons.mozilla.org/en-US/thunderbird/addon/theme-font-size-changer/   

GMAIL LOGIN FAILS
 Be sure that the Gmail setting for using LESS SECURE APP is turned on. 

LANGUAGE 
 If your “Trash” bin is called

“Deleted” instead of “Trash”,
then you have the
“English-British” version of
Thunderbird installed instead
of the “English-US” version.
Just download the latest “US
English” version of
Thunderbird from mozilla.org
and install it.    

LINE SPACING TOO WIDE:
 The Display Line Spacing
for folders pane and the
message list (eg:  Inbox):

 To get the line spacing back
to normal, try this tip:  

http://cimddwc.net/2011/06/30/th
underbird-5-zeilenhoehe-in-bau
m-und-liste-aendern/?langswitch
_lang=en  



C:\users\<username>\AppData\
Roaming\thunderbird\profiles\<profilename>\chrome\userChrome.css  . Make the entry look like this: 
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listitem, treechildren::-moz-tree-row {

    min-height: -2px !important;

} 
treechildren::-moz-tree-row {
    margin-bottom: -4px !important;
}
treechildren::-moz-tree-row(hover),
 treechildren::-moz-tree-row(selected) {
     margin-bottom: 0px !important;
}
/* Row Height*/ treechildren::-moz-tree-row {

   margin-top: -5px !important;
   margin-bottom: 0px !important;

}

Success )



MESSAGE FILTERS  
 Message filters can automatically route unread mail to specific folders for your convenience.
 Unread mail sent to a custom folder can be identified easily. Any Folder containing unread mail

items will show as “BOLD”  and will list the number of unread items to the right of the Folder name 
 Message Filters can also send mail to a "Junk" folder from people who are not in any of your

address books or from those whom you dislike.
 For a step by step tutorial on setting up message filters, see:  http://kb.mozillazine.org/Message_Filters

 For Tutorials and other info about Thunderbird, see the Mozilla knowledge base at: 
http://kb.mozillazine.org/Knowledge_Base  In the search box, enter the desire topic.  

MULTIPLE IDENTITIES: See my “THUNDERBIRD SETUP” sheet for tips on Identities.  
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PASSWORDS - CHANGING SAVED PASSWORDS:
 You cannot change a saved password. You must remove the old saved Password entry, and then

re-enter the correct password during log-in. NOTE: Be aware that some providers require separate
password entries for log-in (IMAP or POP) and for sending a message (SMTP) so you may have to
remove both and then save the password twice.

 To remove a saved Password, go to the Thunderbird Password Manager: (Tools > Options > Security >
Passwords Tab). Click on "Saved Passwords", click on the desired entry, then click "Remove" to
delete the entry or "Remove all" to start from scratch.  

 Now, during the mail log-in, check the box “ Use Password Manager to remember this password”

 For some providers, you may have to do this again the first time you send a message.

PROFILE MANAGER
    If you prefer, you can try out Thunderbird's Profile Manager. This uses a separate instance of
Thunderbird for each e-mail setup, keeping each account totally separate. The disadvantage is that
you can only run one instance of Thunderbird at a time and you have to close that one and reopen
another to switch from one Account to the next. This is very annoying. For more info about Thunderbird
Profiles, see: http://www.mozilla.org/support/thunderbird/profile

RETURN RECEIPTS
 ONE E-MAIL: To request a return receipt while composing an e-mail, click (Options > Return receipt).

The recipent will see your request and hopefully say yes.

 ONE ACCOUNT: To specify the default Return Receipt handling for both outgoing and incoming
mails, click (Tools > Account settings). In the Left-hand column (under the desired Account Name), click
Return Receipts. Now, Customize all desired Return Receipt actions for this Account and click OK
to exit.

 ALL ACCOUNTS: (Global settings). To specify the default Return Receipt handling for both
outgoing and incoming mail, click (Tools > Options > Advanced Icon > General tab > Return Receipts button) .
Now, set up all desired Return Receipt actions for this Account and click OK to exit. Also, for each
account go to (Tools > Account settings). In the Left-hand column (under the desired Account Name),
click Return Receipts. Now Make sure each account is set for “Use my global return receipt
preferences for this account”.

 “AOL” NOTE: Apparently AOL does not permit the requesting of Return Receipt in your outgoing
mail. If you have an AOL address you can acknowledge a received request, but you cannot send
one with your outgoing e-mails. The request just disappears.   

SEND BUTTON OR “COMPOSE TOOLBAR” IS MISSING
 Click “Write” to open a new message. Press Ctrl+F10 and the menu bar should show up. Click on

(View > Toolbars > Menu Bar) so that is is checked. Then click (View > Toolbars > Composition Toolbar) so that
it is checked.   
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SET UP "IMAP" MAIL ITEMS TO BE SAVED LOCALLY ON YOU R HARD-DRIVE
(Webmail): 

1. Normally all IMAP Mail is stored on the provider's server. If you are tired of AOL or other IMAP
provider erasing your old e-mail, you can do one of two things, 1) Convert your account to POP (if
the provider allows), or 2) Store some or all of your e-mail locally. You should do this only if you
access your IMAP Account from just one PC, since your locally stored mail will NOT be accessible
from other PC's. To permanently save your messages off-line on your PC, you simply create your
own custom “Local Folders” in Thunderbird and then drag selected messages to these folders or
route them using message filters. (Note: In the instructions below, if you are using GMAIL or any
provider other than AOL, simply substitute GMAIL or the other provider name instead of AOL. ie:
"GMAIL Drafts")

2. First, from the Thunderbird Main Screen, create the following 4 subfolders in Thunderbird's "Local
Folders". Click on Local Folders, then (File > New > Folder)  Name them;  "AOL Sent", "AOL Drafts",
"AOL Templates", and "AOL MISC". Be sure the box says Create as a subfolder of “Local Folders”.
You can add other folders later.

3. Now, from the Copies and Folders screen, set up the routing of selected messages  (Tools > Account

Settings > Copies & Folders [Below your selected AOL or GMAIL Account]).  Specify your newly created custom
Local Folders for “Sent”, “Drafts”, and “Templates” as follows: 

Under "When sending messages, automatically:" 
Check the box: " Place a copy in:", then select " Other:", and select   "AOL Sent on Local
Folders"

Under Drafts and Templates, "Keep message drafts in:" 
Select " Other:" and select "AOL Drafts on Local Folders"

Under Drafts and Templates, "Keep message templates in:" 
Select " Other:"  and select "AOL Templates on Local Folders"   

4. Other subfolders can be created under "Local Folders" as desired to manually store mail items on
your PC using a click&drag or by routing mail automatically to your Local Folders with Message
Filters. See the above section on Message Filters.    

SLOW - CAUSES FOR THUNDERBIRD RUNNING SLOW:
    LARGE ATTACHMENTS : Having too many e-mails with large attachments can slow everything

down. Attachments should be “Detached”, “Saved”, or “Deleted” as soon as you receive the email so
you don’t forget.   

    LARGE E-MAILS : The column header in Thunderbird, by default, does not include the email “Size”.
You can add “Size” to the Header titles by clicking the little Icon on the far right of the column titles,
then click to select “Size”. Now you can see which emails are too big and delete or archive them.  

    “POP” MAIL:  Same as with Outlook, when your active mail folder gets too big it will slow down POP
Mail. This means it is time to DELETE or ARCHIVE some of your mail, and then Compact the
Folders. 
 DELETE MAIL: 

1) Deleting mail items merely moves them to the “Trash” folder, but does not actually delete them
or reduce the size of your mail system. 

2) To REALLY delete emails, you must then delete them from the “Trash” folder by clicking (File >

Empty Trash). This finally deletes the mail, but still does not reduce the size of your mail folders.  
3) COMPACT the mail folders with (File > Compact Folders) to reduce the size of the mail system. 
4) To keep your mail compacted automatically, make sure your "compact folders" settings are as

shown above in the COMPACTING MAIL FOLDERS Topic. 

 ARCHIVE MAIL: See the section above on ARCHIVING MAIL. 
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   “IMAP” MAIL:
 Thunderbird can be set up two ways. To Syncronize your mail or Not Syncronize your mail. (Tools >

Account settings > Syncronization & Storage). To Syncronize, the box must be checked for “ Keep
messages for this account on this computer”. To NOT Syncronize, the box is NOT checked for “
Keep messages for this account on this computer”.

 Syncronizing Active: Thunderbird downloads copies of all your emails (including attachments) and
keeps them up to date with the server. When first setting up Thunderbird the initial syncronization
can take many minutes even hours depending on how many emails you have. After that, your IMAP
mail runs very fast.  

 Syncronizing Not Active: Thunderbird only downloads the mail Headers ahead of time. Once you
click on an e-mail or attachment, it has to be downloaded before you can view it, thus making IMAP
Mail seem slow.  The speed of your connection is important.  Also see the antivirus scan comments
above. 

 Note: The first time you run Thunderbird on a newly installed IMAP Account, it will go very slow as it
synchronizes the headers with the server. Also the first time you open each folder, it will go slow
until all the headers in that folder download and synchronize. This only happens the first time after
first installing a new IMAP Account on Thunderbird and is normal. 

   GLOBAL DATABASE MAY BE CORRUPTED:
 The Global Database, ("Gloda" for short), is an indexing system that enables Thunderbird to search

messages. Rebuilding the Global Database re-indexes messages and address book cards.

 Check out this link for instructions: 
http://https://support.mozillamessaging.com/en-US/kb/rebuilding-global-database?s=file+indexing&as=s

   ATTACHMENT SAVING IS SLOW: This can be caused by a bloated "downloads.rdf" file in your
Thunderbird profile folder. Try the following:

C:\Documents and Settings\Jim\Application Data\Thunderbird\Profiles\xyxyxyxyxy.username@yourisp 
1. Exit Thunderbird if it is running.
2. Recommended: make a temporary backup of your Thunderbird profile folder (or at least of the
downloads.rdf file).
3. Delete the downloads.rdf file from your profile folder.
REF:  http://kb.mozillazine.org/Attachment_save_slow_-_Thunderbird  

    ANTI-VIRUS PROGRAMS THAT DO E-MAIL SCANS
 A big reason large e-mails or attachments can download slowly is if your antivirus program is

scanning all incoming and outgoing email. This is most annoying with IMAP MAIL as it scans each
item as it downloads and while you are waiting for it to open.  I always turn off the scanning of
outgoing e-mails, and if my incoming mail is uncomfortably slow to download, I turn off the
scanning of incoming e-mails as well. Your provider has already aggressively scanned your mail for
virus and malware 

UPDATE THUNDERBIRD TO THE LATEST VERSION:    
 Windows 7/8 you need to be in an Admin Account or right-click the TBIRD Icon and click Run as

Administrator. 

 Click Help > About Thunderbird
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