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GET & INSTALL FIREFOX  
 To download Firefox, you can either Google the word firefox, or go directly to: 

http://www.mozilla.com/en-US/firefox/, and click the “Download Firefox” button.

 To install Firefox, simply double-click the downloaded file. The wizard will ask you if you want to
import Favorites from Internet Explorer. Say "Yes". Note: In Firefox, "Favorites" are called
"Bookmarks".  

SETUP & CONFIGURE FIREFOX:   Here are my recommended settings to enhance the
convenience and security of Firefox. I mostly list items that vary from the default. If you don't see an item
listed here, I suggest you leave it alone.       
 1. MENU BAR: I like the old fashioned Menu Bar to show (File Edit View etc.....). To do this, right-click

most anywhere on the URL Navigation Toolbar, then click to check “Menu Bar”. 

 2. TOOLBARS: Click View, and click to check the Bookmarks toolbar. 

 3. OPTIONS setup: (click Tools > Options): (For additional info, see: http://www.tweakguides.com/Firefox_1.html )

General  Tab
Startup  - 

 Always check to see if Firefox is your default browser.
Home Page setup:
 Set up the desired pages for each Tab the way you want before going to (Tools > Options) and

then just click the "Use Current Pages" button. 
Tabs

 Open links in new tabs instead of new windows. 
 When you open a link in a new tab, switch to it immeditately.  

Fonts & Colors : 
Set the default font size to your liking. I like Size 16 or 18 for my eyes.
I use the default settings for everything else. 

Downloads:  
 Choose Save files to “Downloads” folder.   

Applications  
The default settings should work. 

If you have trouble viewing PDF's, first make sure Acrobat Reader DC is at the latest version. If
so and it still fails, try this: Under each entry for Adobe Acrobat type Documents, select  "Use
Adobe Acrobat Reader DC (default)".   NOTE: The Action to: "Use Adobe Acrobat (in
Firefox)" is more secure, but can be problematic.

DRM Content
 Play DRM-controlled content

Firefox Updates : 
Under “Firefox updates”, select: “Automatically install updates”.  

Select:  Warn me if this will disable any of my add-ons.
Browsing

 Use autoscrolling     
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 Use smooth scrolling. Leave it unchecked. I do not recommend this option .
 Always use the Cursor keys to navigate witing pages
 Search for text when you start typing.  

Network Proxy:  
Click the <Settings> button, and choose   Use system proxy settings

Search  Tab
Search Bar

 Add Search bar in toolbar

Default Search Engine
Change the Default Search Engine to “Google”. 

One-Click Search Engines
I always remove the Bing and Yahoo search engines.   .   

Privacy & Security Tab
Forms & Passwords : 
  Remember logins and passwords for sites. (Note: I use this feature, but it is NOT recommended

by security experts).  
 Autofill addresses ( I do not use this but it is on by default)

  Use a master password.  (I do not use a master password)

   History
  Select: Firefox will: "Use custom settings for history"
 Always use private browsing mode, (You can check it if you want, but all histories will be erased)

 Remember my browsing and download history.
 Remember search and form history. (Uncheck for added privacy)
 Accept Cookies from sites.

 Accept third-party cookies. Set to “Never”  
Keep until:    "I close Firefox"

 Clear history when Firefox closes. 
     Click the <Settings> button and choose what you want to delete when clearing your private

data. (I check all the History boxes except " Browsing & Download History" ). I leave the
Data boxes unchecked. 

   Address Bar : 
    When using the address bar, suggest

 Browsing History (default is checked)
 Bookmarks (default is checked)
 Open tabs (default is checked)

   Cached Web Content : 
 Override automatic cache management. Make sure this box is un-checked. 

    Note: To clear the cache immediately, click the "Clear Now" button on the right of the
Offline Storage area.

   Tracking Protection
   Use Tracking protection to block known trackers. 
  Only in private windows.

   Send websites a “Do Not Track” signal that you don’t want to be tracked    
 Always

   Permissions
   Leave all as default
 Block pop-up windows
 Warn you when websites try to install add-ons
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   Security  Tab
Leave everything a default

.
 Block reported attack sites.

  Block reported web forgeries.

Firefox Account tab
For Sync and other options, you must create and log into a Firefox Account.  “Sync” is for

synchronizing Firefox settings with all your devices. For help with Sync, see:  
http://support.mozilla.com/en-US/kb/how-do-i-set-up-firefox-sync      

4. Import Bookmarks from IE, if desired. (File > Import). Under "Import Options, Bookmarks, history,
Passwords and other data from". choose:  Microsoft Internet Explorer. 

5. Install the WOT add-on for Firefox. (see below)  

6. Install Acrobat Reader DC or higher and make sure that Firefox opens a PDF file properly.

7. Install SANDBOXIE and set it up per my “Sandboxie” writeup.

8. If desired, install Flash for both Firefox and IE (test by Googling: test flash)  

FIREFOX TIPS   
 CACHE DISPLAY: To see the maximum size of your cache and how much of it is currently being

used, type into the URL box:   about:cache

 Microsoft .NET FRAMEWORK Assistant add-on. Don’t use (Security vulnerability)

 WORK OFFLINE MODE: To disable Work Offline Mode from automatically turning on when
Internet is not available (Ver 3.6 and higher). 

 Type into the URL box:   about:config   then verify that network.manage-offline-status is set to:
false   (This setting should already be there by default).

 If it is not, then type into the URL box:   about:config   Right-click anywhere, click New >
Boolean. Name the new preference: network.manage-offline-status ,  then set the new
preference to: false   (This setting should already be there by default.

 PRIVATE BROWSING: When in Private Browsing mode, no history will be kept of your activities.  

 Click ( File > New Private Menu) for a temporary private browsing tab

 To permanently activate Private Browsing all the time, go to (Tools > Options > Privacy tab). Click to
check “ Always use private browsing mode”.

 RELOAD A WEBPAGE: To reload a webpage (including its favicon) from its server (not the cache),
hold down the <Shift> key while clicking the Reload Icon.

 DOWNLOADS MANAGER: 
 Firefox ver 20 and higher uses a new Downloads Manager. To open the Downloads Manager,

click the “Down Arrow” near the right end of the Navigation Toolbar.     

RECOMMENDED ADD-ON'S
 FLASH VIDEO YOUTUBE DOWNLOADER :   

http://addons.mozilla.org/en-us/firefox/addon/flash-video-downloader/?src=search    

 CLASSIC THEME RESTORER : Makes Icons look like old Firefox (I love it). May not work with
newer versions:  http://addons.mozilla.org/en-US/firefox/addon/classicthemerestorer/               

 VIDEO DOWNLOADHELPER: http://addons.mozilla.org/en-us/firefox/addon/flash-video-downloader-youtube/
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 NoSquint  (Set large default text & image sizes with a custom zoom for each website. It also offers many other custom
viewing options, both globally and by site) http://addons.mozilla.org/en-US/firefox/addon/2592

 NoScript  (For extra, extra, extra security): http://www.mywot.com/en/support/tutorials   

 Theme Font and Size Changer:  http://addons.mozilla.org/en-us/firefox/addon/theme-font-size-changer/    

 Tree Style Tabs: http://addons.mozilla.org/en-US/firefox/addon/5890  

 Adblock Plus: http://addons.mozilla.org/en-US/firefox/addon/adblock-plus/?src=external-denblog

 uBlock Origin  (Better Ad Blocker than AdBLockPlus): http://addons.mozilla.org/en-US/firefox/addon/ublock-origin/ 
 FIREFTP (Upload files to a website): 
 FIREFTP BUTTON
 WOT (Web Of Trust): 

REFRESH ALL FIREFOX SETTINGS:
 Save any important info, then click: (Help > Troubleshooting Information > Reset Firefox). Note: This will

remove everything that was customized: all bookmarks, browsing history, tabs,  passwords,
homepages, security settings, addons, etc. 

 What happens when you Refresh Firefox.  
 https://www.guidingtech.com/what-happens-when-you-refresh-firefox/

SAFE-MODE:
 Click: (Help > Troubleshooting Information > Try Safe Mode). Click on “Restart with add-ons disabled”

ADD-ON COMPATIBILITY CHECKING:  Before updating to a new version of Firefox, you can
see if your current add-on’s are compatible with the new version with the “Is it Compatible” add-on:   

                     http://addons.mozilla.org/en-us/firefox/addon/is-it-compatible/  

TOOLBAR TIPS
 TOOLBAR ICONS FOR “RELOAD” AND “STOP”: To keep the “Reload Current page” icon and

“Stop Loading” icon from merging into the URL box, open the Customize Toolbar window. Drag a
separator to between the URL box and the Reload Icon. Then drag a separator to between the
Reload Icon and the Stop Icon. Click Done.

UPDATE FIREFOX TO THE LATEST VERSION:    
 Windows 7/8/10 you need to be in an Administrator authority Account or right-click the FIREFOX

Icon and click Run as Administrator.  

 Click Help > About Firefox 

"WOT" ADD-ON TIPS (Web Of Trust for more secure browsing)
 This add-on does a great job of boosting your safety while browsing by identifying trustworthy sites.

(I now use it instead of McAfee Site Advisor or the AVG Link Scanner).  

 WOT enhances the results of your Google searches with little colored circles to the right of each
search result. Green is good. Yellow or Orange is suspect. Red means do not go to this site.  

 To install WOT in Firefox either google WOT, or click (Tools > Add-ons) and put WOT in the search
box. Select WOT, click Install, then Restart. 

 When installing WOT, you will be asked to accept the terms of service and you will be taken to the
mywot.com website to set up your settings. Just click “Apply settings” for now. You can change the
settings at any time by right-clicking the WOT circle on the Firefox toolbar.  

 For WOT tutorials, go to:  http://www.mywot.com/en/support/tutorials

 For help with WOT, go to:  http://www.mywot.com/en/support        
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TROUBLESHOOTING FIREFOX: 
1. FIREFOX FAILS TO START UP : 

a. If you have not already re-started your Windows System, then shutdown the PC and power
back up. This fixes most Firefox startup issues.  If Firefox still fails to start, continue with these
steps.....

b. TRY FIREFOX SAFE-MODE: 
1) SAFE-MODE disables add-ons, toolbars, and other stuff. If Firefox works in Safe-mode, try

disabling or removing all the Add-ons & Toolbars, then start up Firefox in regular mode. If
Firefox now runs, you can re-install the Add-ons one at a time.   

2) To enter SAFE-MODE in Firefox 4.x and HIGHER: With Firefox fully shutdown, hold the
Shift-key down while double-clicking the Firefox Icon. 

3) If it works in Safe-Mode and the add-ons are not the cause, try turning off “Hardware
Acceleration in Firefox: http://support.mozilla.org/en-US/kb/forum-response-disable-hardware-acceleration   

c. REMOVE THESE ADD-ONS: "AVG Safesearch" and "McAfee Site Advisor" are common
troublemakers. Remove both of them. Use the WOT add-on for security. 

d. BAD FIREFOX PROFILE: Try starting Firefox in another User Account.  If that works, then the
Firefox program is OK, but the Firefox Profile for your User Account is messed up. To make a
fresh profile, do the following:

1) BOOKMARKS: Hopefully before starting this, you already have a backup of your Firefox
Bookmarks. If not:
a) If Firefox will open, save your Bookmarks: Click the “Firefox” button in the far upper left

hand corner of the Firefox window. Click Bookmarks > Show all Bookmarks, then use
the export function to save all the bookmarks. Use safe-mode if necessary. 

b) If Firefox will not open, you can try backing up JUST THE BOOKMARKS using the
MOZBACKUP Utility (This should work, even if Firefox will not start). Do not try to save
the rest of the profile data.    

c) Otherwise, you can recover the Bookmarks by saving the bookmarks.html  file in a safe
place:  (Note, the xxxxxxxx can be any random alphanumeric data):
i) For XP:        C:\Documents and Settings\<UserName>\ApplicationData\

Mozilla\Firefox\Profiles\xxxxxxxxx.default\bookmarks.html  
ii) For WIN 7/8/10:  C:\Users\<UserName>\AppData\Roaming\

Mozilla\Firefox\Profiles\xxxxxxxxx.default\bookmarks.html   

2) Make a list of all installed Add-ons. 

3) Remove/uninstall Firefox using Add/Remove Programs (XP) or Programs and Features
(Windows 7/8/10).

4) For XP, go to (C:\Documents and settings\<UserName>\Application Data\), and delete the
Mozilla folder. (Note: This destroys your profile including all bookmarks)

5) For Windows 7/8/10, go to C:\Users\<UserName>\Application Data\Roaming\), \), and
delete the Mozilla folder. (Note: This destroys your profile including all bookmarks)

6) Re-install Firefox. 

7) If Firefox now starts up OK, import your saved Bookmarks, then re-install any Add-ons. 

2. AUDIO / SOUND MISSING WHEN SANDBOXED OR SANDBOXIE E RROR SBIE2205 
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a. Re: Firefox (56, 57, and 58) print problem or missing sound problem only when sandboxed.
Post by Barb@Invincea » Tue Aug 29, 2017 6:39 pm

b. Also Re: Sandboxie error SBIE2205 CreateDesktop error with Firefox 60, only when
sandboxed.

c. Open Firefox without Sandboxie
d. Type about:config and accept the risk
e. Search for security.sandbox
f. Switch security.sandbox.content.level to 2 (if needed switch it to 1 or 0 ).
g. Close Firefox
h. Relaunch FIREFOX with Sandboxie and re-try. If it still fails, reboot the PC and try Sandboxie

again.  

3. FIREFOX HANGS, STOPS RESPONDING, OR GETS AN ERROR DURING STARTUP:
a. Try these tips from Mozilla:    http://support.mozilla.org/en-US/kb/firefox-hangs-or-not-responding 

4. FIREFOX TAKES TOO LONG TO START:  
a. Note: A long startup is typical for Firefox on older PC's. 

b. Using "Live Bookmarks" can slow down the start up. 

c. Using Too many "Add-ons" can slow down the start up. Especially McAfee Site Advisor

d. Multiple Tabs that are set up to auto-logon into sites (like iGoogle or Yahoo mail) will slow the
start of Firefox. 

e. Reduce the Java cache size. See the next tip under SLOW. 

5. SLOW:  
a. JAVA CACHE: Clear the Java cache and then set the Java cache size to 50 MB. (Control Panel >

Java > General tab > Temporary Internet Files "Settings" button . Click "Delete Files", then set the Disk Space = 50
MB. Click <OK>, <OK> to save the new value and exit.) Note: Default is 1000 MB.

b. IPV6: For Firefox version or higher, try disabling IPV6. In the URL Box, type: about:config:
In about:config, enter a filter value = ipv6.  Then double-click the resulting line called:
"network.dns.disableIPv6". That will change it from "false" to "true".

c. SLOW LOADING WEB PAGES. Try these tips: 
1) In about:config, change the:     network.http.keep-alive setting to true

2) In about:config, change the:     network.prefetch-next setting to false

3) In about:config, change the:     network.dns.disableIPv6 setting to true

4) In about:config, change the:     network.dns.disablePrefetch setting to true

5) In about:config, change the:     network.http.pipelining setting to true

6) In about:config, change the:     network.http.proxy.pipelining setting to true

7) In about:config, change the:     network.http.spdy.enabled setting to true
  (Firefox version 11 and higher only)

8) In about:config, change the:     network.http.pipelining.maxrequests” to a number like 25.
This will allow it to make 25 requests at once. (The default is 4)

9) To give Firefox more time to load a page without giving a script timeout error: 
 In about:config, change the:    dom.max_script_run_time        set to larger# than 10 (sec’s)
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10) Make sure Firefox connection is set for NO PROXY. (Tools > Options > Advanced tab > Network tab

> Connection settings > No Proxy)

11) Try disabling all add-ons and see if that helps. If so, then determine which add-on is the
culprit one by one. 

6. DOWNLOADS FOLDER IS BLANK: 
a. Try disabling all add-ons. If it works, find out which add-on did it. 

b. Try this troubleshooting guide: http://support.mozilla.org/en-US/kb/Downloads%20window%20is%20blank   

7. ADD-ON COMPATIBILITY PROBLEMS:
a. If a Firefox update kills your add-on, try installing the “Add-on Compatibility Reporter” add-on.

This add-on disables “Add-on Compatibility checking” and allows many add-ons to run on
newer versions of Firefox. 

8. LOST ALL BOOKMARKS : 
a. For recovery Tips, see Smart Computing: Jan 2008 issue, Page 80. You can search the

smartcomputing.com site for: firefox lost bookmarks (select a date range of after 12/2007) 

b. Look in the “BOOKMARKSBACKUPS” folder to see if any automatic backups are there.  (Note,
the xxxxxxxx can be any random alphanumeric data):
1) For XP:        C:\Documents and Settings\<UserName>\ApplicationData\

Mozilla\Firefox\Profiles\xxxxxxxxx.default\bookmarkbackups\  
2) For WIN 7:  C:\Users\<UserName>\AppData\Roaming\

Mozilla\Firefox\Profiles\xxxxxxxxx.default\bookmarkbackups\     .

9. AUTOMATIC SITE LOG-ON’s DO NOT WORK WITH FIREFOX, B UT WORK FINE WITH
IINTERNET EXPLORER. (In other words, sites like iGoogle and Yahoo Mail make you sign-in
every time you start Firefox). The cause is that your site cookies are being deleted.  
 For an automatic logon to work with iGoogle, Yahoo Mail, Facebook, or any site, the following

conditions must be met. 
1) In Firefox, Cookies must be allowed and kept for the desired sites. There is no way to keep

cookies just for certain sites, so you must set up Firefox as follows: 

2) Go to the (Tools > Options > Privacy Icon) and make sure the box is checked to: “ Accept
cookies from sites. Also, make sure it says Keep until: “they expire”.

3) If you use the "Clear history" option, go to (Tools > Options > Privacy icon > Clear history when Firefox

closes > "Settings" button), and UN-CHECK the delete boxes for  " Cookies and " Saved
passwords". 

4) On the iGoogle, Yahoo, Facebook, or other regularly used "Sign in" screens, you must first
check the box called: " Keep me signed in" or “ Remember Me” before you click the
"sign in" button. (Warning: Never check “Remember me” on a public computer)

5) If you use the CCleaner utility, you can specify those same sites on a list of cookies to NOT
be deleted. That way CCleaner will never delete them. (In CCleaner, run Analyze, then click Options
> Cookies. Highlight the desired Cookie in the delete column and click the “->” button to move it to the Keep
column). 

10. PDF FILE PROBLEMS :
a. Problems Viewing some PDF FILES with Firefox. Also may hang trying to open a PDF.  Fix:

Reconfigure Adobe Reader (or Acrobat) to display the PDF outside Firefox in a separate
window:   
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1) Start Adobe Reader (or Acrobat), and in the Reader, click on (Edit > Preferences > Internet).  

2) Un-check the box: " Display readmode by default". 

3) Click OK to exit. Close the Reader, Restart the PC.

4) WARNING: Future updates to Adobe Reader re-check the box by default. You must
manually uncheck the box after every major Adobe Reader update.

5) If this does not work, then in Firefox, go to (Tools > Options > Applications tab). Scroll down to
the “Adobe Acrobat Document” entry (There may be several slightly different entries).
Make sure the Action is what you want for each entry. I choose “Adobe Reader x.x” for
each one. 

b. Cannot print PDF Documents. If you are viewing the document “inside” Firefox, be sure you are
clicking on the correct Printer Icon. Adobe has its own toolbar inside the browser with its own
Printer Icon. Use the Printer Icon on the lower of two Toolbars. NOTE: It is better and less
confusing to set up Adobe to display the PDF documents in a stand-alone Adobe Reader
window. See the previous step for details on setting this in Adobe Reader. 

c. For problems opening PDF’s in Firefox version 7 and higher; first make sure you are at Adobe
Reader version 10 or higher. If you still have problems, go to (Tools > Options > Applications tab), and
try different Adobe options to find which Action works for you.       
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